WordPress 5.0 & Gutenberg

All Greatives WordPress themes are fully compatible with WordPress 5.0. There is nothing specific that is required from our customers apart from updating theme and required plugins to their latest versions. This is just enough to ensure the compatibility with the latest WordPress version.

About the new editor, Gutenberg, we are following its development status and we will soon provide compatibility into our themes. We still believe that Gutenberg is not ready to be used on production sites as there are limited options. However, since it is part of WordPress core we have to support it.

Last but not least, for anyone who prefers to disable the Gutenberg new WordPress editor, there is an option under WPBakery Page Builder > General Settings.

So, before you update to WordPress 5.0 it is recommended:

  1. Update Greatives theme to its latest version.
  2. Ensure that you have also updated the required plugins (Extension Plugin & WPBakery Page Builder)
  3. Disable the Gutenberg editor in order to use our handcrafted elements.

If you have any further questions or need assistance please use our Support Forum. Our support team will be glad to assist you.

Related Articles